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I’m trying to refund a customer but it won’t let me?

How to identify issues with refunding customers

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When trying to refund a customer, an error message of ‘Refund failed’ where the refund amount is greater than the charge amount for the order may occur.

Cause of the issue

 

Where the refund amount is more than the card payment that was made. Each transaction is linked to a specific amount that was charged for the original order through Stripe. If credit was used to fulfil part of the payment and you are trying to refund the whole order order amount to their card this will exceed the original payment amount. This will prevent the refund from being possible and will produce the error message.

 
 
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How to resolve this issue

  • Refund the full amount to credit rather than the card.
  • If the order has more than one item in you can part refund credit so the refund value remaining is less or equal to the original card payment amount. When a successful card payment has taken place this will show in the bottom right of the order record and will detail the amount that the customer paid for on their card.
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